summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-10-22 22:28:52 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-10-22 22:28:52 +0000
commit2e5e8fd89540bc4301e6a94df022c41b44eca31a (patch)
tree71340018acf226c4f9469c8d22fed3d097b16102 /configure.in
parent359d93233200a4425f9d560cf519d32e5f47576d (diff)
* configure.in (warnflags): use -Wextra instead of -Wall.
* gc.c (mark_current_machine_context): get rid of warning. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@25437 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 3b6d2bb111..7f7a649c97 100644
--- a/configure.in
+++ b/configure.in
@@ -389,7 +389,7 @@ dnl compiler section {
if test "$GCC:${warnflags+set}:no" = yes::no; then
save_CFLAGS="$CFLAGS"
- for wflag in -Wall -Wno-unused-parameter -Wno-parentheses -Wpointer-arith -Wwrite-strings \
+ for wflag in -Wextra -Wno-unused-parameter -Wno-parentheses -Wpointer-arith -Wwrite-strings \
-Wno-missing-field-initializers -Wshorten-64-to-32; do
CFLAGS="$CFLAGS $wflag"
AC_MSG_CHECKING([whether $wflag is accepted])