summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-02-27 05:24:01 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-02-27 05:24:01 +0000
commit2e3fc1f06427c46aff50ba8eebe2f3fcb76dc96b (patch)
tree7151a15a207630c3cc67ac9d964efe133436485f /configure.in
parent46e0ce84d53dbb565d6a3460b2bd37a8250ad8d7 (diff)
configure.in: escape double-quotes
* configure.in (unexpand_shvar): escape double-quotes in backquotes in double-quotes for some shells. [Bug #7959] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@39525 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 81329cc8aa..19fa23e2a9 100644
--- a/configure.in
+++ b/configure.in
@@ -3286,7 +3286,7 @@ unexpand_shvar() {
test "$#" -eq 0 && return
for n do
eval v='"$'$n'"'
- v="`echo \"$v\" | sed -e ['s/${[^${}"]*}/"&"/g'] -e ['s/[][$|.\\?*]/\\\\&/g']`"
+ v="`echo \"$v\" | sed -e ['s/${[^${}\"]*}/\"&\"/g'] -e ['s/[][$|.\\?*]/\\\\&/g']`"
if test -n "$v"; then
expr=["${expr};s|"'\("[^$"]*\)'"$v|\\1\${$n}\"|g"]
AS_CASE(["$v"], [*'${'*'}'*], [expr=["$expr;s|$v|\"\${$n}\"|g"]])