summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-04-18 14:09:04 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-04-18 14:09:04 +0000
commit24620aaf1ce8f3b4c9214d28ea5af581d54586be (patch)
tree40e42bfdbef1926585d3d31dfa2f9c658bed63fd /configure.in
parent5468593e147762d7f9f9fee59097b6781a555093 (diff)
merge revision(s) 35387:
* configure.in (DOT, DOXYGEN): use AC_CHECK_PROGS instead of AC_CHECK_PROG which needs the third argument. [ruby-core:44433] [Bug #6316] * configure.in (PKG_CONFIG): fix condition to skip older version of pkg-config. continue in backticks does not affect outside. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_9_3@35388 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 9632860d3b..6d2468987c 100644
--- a/configure.in
+++ b/configure.in
@@ -365,11 +365,11 @@ fi
MAKEDIRS="$MKDIR_P"
AC_SUBST(MAKEDIRS)
-AC_CHECK_PROG(DOT, dot)
-AC_CHECK_PROG(DOXYGEN, doxygen)
+AC_CHECK_PROGS(DOT, dot)
+AC_CHECK_PROGS(DOXYGEN, doxygen)
-AC_CHECK_PROG(PKG_CONFIG, pkg-config, [], [], [],
- [`$as_dir/$ac_word$ac_exec_ext --print-errors --version > /dev/null 2>&1 || continue`])
+AC_CHECK_PROG(PKG_CONFIG, pkg-config, [pkg-config], [], [],
+ [`"$as_dir/$ac_word$ac_exec_ext" --print-errors --version > /dev/null 2>&1 || echo "$as_dir/$ac_word$ac_exec_ext"`])
# checks for UNIX variants that set C preprocessor variables
AC_USE_SYSTEM_EXTENSIONS