summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-11-19 06:11:36 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-11-19 06:11:36 +0000
commit24512ba1b4be9698f127795d8e9ccfe96640983c (patch)
tree2543ae9d55e5561e166d4bb0938a21a612323bc3 /configure.in
parent15d940b8b0361925e15f412913f346fca4bf3400 (diff)
* configure.in: fix didn't enable_dtrace=yes on auto.
* configure.in: see enable_dtrace for adding libelf on FreeBSD. * common.mk: VPATH is not needed. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@37717 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 7acb4e95ee..183d3ba954 100644
--- a/configure.in
+++ b/configure.in
@@ -1286,10 +1286,6 @@ main()
AC_DEFINE(BROKEN_SETREGID, 1)
ac_cv_sizeof_rlim_t=8],
[freebsd*], [ LIBS="-lm $LIBS"
- if test "${rb_cv_prog_dtrace_g}" = "yes"; then
- # FreeBSD's dtrace requires libelf
- LIBS="-lelf $LIBS"
- fi
ac_cv_func_getpeername=no
ac_cv_func_getsockname=no
ac_cv_func_shutdown=no
@@ -2741,10 +2737,10 @@ AC_ARG_ENABLE(dtrace,
if test "${enable_dtrace}" = "auto"; then
if test x"$DTRACE" != x -a x"$cross_compiling" != xyes; then
RUBY_DTRACE_POSTPROCESS()
+ enable_dtrace=yes
if test "$rb_cv_prog_dtrace_g" = 'yes'; then
RUBY_DTRACE_BSD_BROKEN([enable_dtrace=no], [enable_dtrace=yes])
else
- enable_dtrace=yes
AS_CASE(["$target_os"],
[freebsd*], [enable_dtrace=no]
)
@@ -2778,6 +2774,11 @@ AC_SUBST(DTRACE_OBJ)
AC_SUBST(DTRACE_GLOMMED_OBJ)
AC_SUBST(LIBRUBY_A_OBJS)
+if test "${enable_dtrace}" = "yes"; then
+ # FreeBSD's dtrace requires libelf
+ LIBS="-lelf $LIBS"
+fi
+
}
{ # build section