summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-06-13 08:51:04 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-06-13 08:51:04 +0000
commit23838b93e8a4a9030ba28e5206f0f3e49cf59f6c (patch)
tree09dc8d17ca668496812a42c1d45c9c4bc3533231 /configure.in
parent0c7dab5df958d65b0e4b3216c23f7b13a11eaeee (diff)
configure.in: option for cygwin
* configure.in: cygwin needs C99 for some stuff, e.g., pthread_attr_setstacksize, sched_yield. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@36059 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ab53e8a2c2..e94b3d6309 100644
--- a/configure.in
+++ b/configure.in
@@ -617,6 +617,11 @@ if test "$GCC" = yes; then
# comments. We bypass ANSI C mode for them. Otherwise
# extension libs cannot include those headers.
],
+ [cygwin*], [
+ # needs C99 to isinf() and so on
+ RUBY_APPEND_OPTION(warnflags, -ansi -std=c99)
+ RUBY_APPEND_OPTION(rb_cv_warnflags, -ansi -std=c99)
+ ],
[
# ANSI (no XCFLAGS because this is C only)
RUBY_TRY_CFLAGS(-ansi -std=iso9899:199409, [