summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-11-19 07:17:56 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-11-19 07:17:56 +0000
commit2370556d3d8ec4138c4326208a6da7c1c485e908 (patch)
treea031c959eb3491c177b66259f5548a2341d2ce44 /configure.in
parenta824a6187d202ba57bcdf874c53606c103c357e4 (diff)
configure.in: no -lelf
* configure.in (LIBS): libelf is need on only FreeBSD. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@37720 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 183d3ba954..f2d22ef6f3 100644
--- a/configure.in
+++ b/configure.in
@@ -2758,7 +2758,7 @@ if test "${enable_dtrace}" = "yes"; then
AC_MSG_ERROR([--enable-dtrace, however, cross compiling])
else
RUBY_DTRACE_POSTPROCESS()
- if test "$rb_cv_prog_dtrace_g" = 'yes'; then
+ if test "$rb_cv_prog_dtrace_g" = 'yes'; then
RUBY_DTRACE_BSD_BROKEN([AC_MSG_ERROR([--enable-dtrace, however, USDT is broken])], [])
DTRACE_OBJ='probes.$(OBJEXT)'
DTRACE_GLOMMED_OBJ='ruby-glommed.$(OBJEXT)'
@@ -2774,10 +2774,10 @@ AC_SUBST(DTRACE_OBJ)
AC_SUBST(DTRACE_GLOMMED_OBJ)
AC_SUBST(LIBRUBY_A_OBJS)
-if test "${enable_dtrace}" = "yes"; then
+AS_CASE("${enable_dtrace}:${target_os}", [yes:freebsd*], [
# FreeBSD's dtrace requires libelf
LIBS="-lelf $LIBS"
-fi
+])
}
{ # build section