summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-05-22 10:39:48 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-05-22 10:39:48 +0000
commit210f863906c34ad524007abb3b045d4b3cba98b1 (patch)
tree5b8a152a0dc10635d17f62eb5cae727320b12b2b /configure.in
parentfa244db49b16d05c0042e01ef8faa9190acc5922 (diff)
revert File::Statfs [Feature #9772]
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@46042 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in37
1 files changed, 0 insertions, 37 deletions
diff --git a/configure.in b/configure.in
index 97e95eeb52..28c227b655 100644
--- a/configure.in
+++ b/configure.in
@@ -1068,8 +1068,6 @@ main()
ac_cv_func_clock_gettime=yes
ac_cv_func_clock_getres=yes
ac_cv_func_malloc_usable_size=no
- ac_cv_type_struct_statfs=yes
- ac_cv_member_struct_statfs_f_fstypename=yes
{ test "$target_cpu" = x64 && ac_cv_func___builtin_setjmp=no; }
AC_CHECK_TYPE([NET_LUID], [], [],
[@%:@include <windows.h>
@@ -1093,7 +1091,6 @@ main()
ac_cv_func_close=no
],
[netbsd*], [ LIBS="-lm $LIBS"
- ac_cv_func_fstatfs=no
],
[dragonfly*], [ LIBS="-lm $LIBS"
# isinf() and isnan() are macros on DragonFly.
@@ -1133,8 +1130,6 @@ AC_CHECK_HEADERS( \
sys/select.h \
sys/time.h \
sys/times.h \
- sys/param.h \
- sys/vfs.h \
syscall.h \
pwd.h \
grp.h \
@@ -1163,9 +1158,6 @@ AC_CHECK_HEADERS( \
malloc/malloc.h \
setjmpex.h
)
-AC_CHECK_HEADERS(sys/mount.h, [], [], [@%:@ifdef HAVE_SYS_PARAM_H
-@%:@ include <sys/param.h>
-@%:@endif])
AC_ARG_WITH([gmp],
[AS_HELP_STRING([--without-gmp],
@@ -1743,33 +1735,6 @@ AC_CHECK_TYPES([struct timezone], [], [], [@%:@ifdef HAVE_TIME_H
@%:@ include <sys/time.h>
@%:@endif])
-AC_CHECK_TYPES([struct statfs], [], [], [@%:@ifdef HAVE_SYS_PARAM_H
-@%:@ include <sys/param.h>
-@%:@endif
-@%:@ifdef HAVE_SYS_MOUNT_H
-@%:@ include <sys/mount.h>
-@%:@endif
-@%:@ifdef HAVE_SYS_VFS_H
-@%:@ include <sys/vfs.h>
-@%:@endif])
-AS_IF([test "$ac_cv_type_struct_statfs" = yes], [
-AC_CHECK_MEMBERS([struct statfs.f_type, struct statfs.f_fstypename], [], [], [@%:@ifdef HAVE_SYS_PARAM_H
-@%:@ include <sys/param.h>
-@%:@endif
-@%:@ifdef HAVE_SYS_MOUNT_H
-@%:@ include <sys/mount.h>
-@%:@endif
-@%:@ifdef HAVE_SYS_VFS_H
-@%:@ include <sys/vfs.h>
-@%:@endif])
-])
-# AIX, HP-UX, NetBSD, Solaris
-AC_CHECK_TYPES([struct statvfs], [], [], [@%:@ include <sys/statvfs.h>])
-# NetBSD
-AC_CHECK_MEMBERS([struct statvfs.f_fstypename], [], [], [@%:@ include <sys/statvfs.h>])
-# AIX, HP-UX, Solaris
-AC_CHECK_MEMBERS([struct statvfs.f_basetype], [], [], [@%:@ include <sys/statvfs.h>])
-
AC_CHECK_TYPES([clockid_t], [], [], [@%:@ifdef HAVE_TIME_H
@%:@ include <time.h>
@%:@endif
@@ -1995,8 +1960,6 @@ AC_CHECK_FUNCS(fcntl)
AC_CHECK_FUNCS(fdatasync)
AC_CHECK_FUNCS(fmod)
AC_CHECK_FUNCS(fork)
-AC_CHECK_FUNCS(fstatfs)
-AC_CHECK_FUNCS(fstatvfs)
AC_CHECK_FUNCS(fsync)
AC_CHECK_FUNCS(ftruncate)
AC_CHECK_FUNCS(ftruncate64) # used for Win32 platform