summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorkosaki <kosaki@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-09-26 00:19:03 +0000
committerkosaki <kosaki@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2011-09-26 00:19:03 +0000
commit20ae79b0c26e2b9ee9441728353f27c571507a4d (patch)
treedbf12b33d1bcf6e65a9e01f98a2fc9dff4231de8 /configure.in
parent6823334c214d9b83ea71de67ab6c5ce1c4fbdfab (diff)
* include/ruby/defines.h: remove NextStep, OpenStep, Rhapsody
support. Last activity of their OSs are 7 years ago. * configure.in: ditto. * dir.c: ditto. * ext/tk/extconf.rb: ditto. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@33337 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 4 insertions, 19 deletions
diff --git a/configure.in b/configure.in
index 64740c6a76..5e6d470b79 100644
--- a/configure.in
+++ b/configure.in
@@ -1965,7 +1965,7 @@ if test "$with_dln_a_out" != yes; then
AC_MSG_CHECKING(whether OS depend dynamic link works)
if test "$GCC" = yes; then
AS_CASE(["$target_os"],
- [nextstep*|openstep*|rhapsody*|darwin*], [
+ [darwin*], [
# The -fno-common is needed if we wish to embed the Ruby interpreter
# into a plugin module of some project (as opposed to embedding it
# within the project's application). The -I/usr/local/include is
@@ -2054,15 +2054,6 @@ if test "$with_dln_a_out" != yes; then
LDFLAGS="$LDFLAGS -Wl,-E"
fi
rb_cv_dlopen=yes],
- [nextstep*], [ : ${LDSHARED='$(CC) -r -nostdlib'}
- LDFLAGS="$LDFLAGS -u libsys_s"
- rb_cv_dlopen=yes],
- [openstep*], [ : ${LDSHARED='$(CC) -dynamic -bundle -undefined suppress'}
- : ${LDFLAGS=""}
- rb_cv_dlopen=yes],
- [rhapsody*], [ : ${LDSHARED='$(CC) -dynamic -bundle -undefined suppress'}
- : ${LDFLAGS=""}
- rb_cv_dlopen=yes],
[darwin*], [ : ${LDSHARED='$(CC) -dynamic -bundle'}
: ${DLDFLAGS="${linker_flag}-undefined${linker_flag:+,}dynamic_lookup ${linker_flag}-multiply_defined${linker_flag:+,}suppress ${linker_flag}-flat_namespace"}
: ${LDFLAGS=""}
@@ -2182,7 +2173,7 @@ else
AS_CASE(["$target_os"],
[hpux*], [
DLEXT=sl],
- [nextstep*|openstep*|rhapsody*|darwin*], [
+ [darwin*], [
RUBY_APPEND_OPTION(XLDFLAGS, [-Wl,-u,_objc_msgSend])
DLEXT=bundle],
[os2-emx*], [
@@ -2220,7 +2211,7 @@ fi
AS_CASE(["$target_os"],
[linux* | gnu* | k*bsd*-gnu | kopensolaris*-gnu], [
STRIP="$STRIP -S -x"],
- [nextstep* | openstep* | rhapsody* | darwin*], [
+ [darwin*], [
STRIP="$STRIP -A -n"])
AC_ARG_WITH(ext,
@@ -2288,7 +2279,7 @@ LIBRUBYARG='$(LIBRUBYARG_STATIC)'
SOLIBS=
AS_CASE(["$target_os"],
- [cygwin*|mingw*|beos*|haiku*|openstep*|nextstep*|rhapsody*|darwin*|os2-emx*], [
+ [cygwin*|mingw*|beos*|haiku*|darwin*|os2-emx*], [
: ${DLDLIBS=""}
],
[
@@ -2480,12 +2471,6 @@ AS_CASE(["$target_os"],
[netbsd*], [
RUBY_APPEND_OPTION(CFLAGS, -pipe)
],
- [nextstep*|openstep*], [
- RUBY_APPEND_OPTION(CPPFLAGS, -I/usr/local/include)
- ],
- [rhapsody*], [
- RUBY_APPEND_OPTIONS(CFLAGS, -pipe -no-precomp)
- ],
[darwin*], [
RUBY_APPEND_OPTION(CFLAGS, -pipe)
],