summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-09-11 12:38:15 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-09-11 12:38:15 +0000
commit1ce66c6203b8f62ba0d8328c5b4433f57c093b21 (patch)
tree3f63c52a31856f359f21efeb6343edffa6c4ec5a /configure.in
parent2620a840702c1b109f20706276d0c8b00d3a7204 (diff)
* tool/config.{guess,sub}: better guess on darwin 10 .
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@24851 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 973256a142..98c08d7c4e 100644
--- a/configure.in
+++ b/configure.in
@@ -202,6 +202,29 @@ if test ${target_archs+set}; then
CFLAGS="$CFLAGS ${ARCH_FLAG}"
LDFLAGS="${LDFLAGS+$LDFLAGS }${ARCH_FLAG}"
else
+ if test x"$target_alias" = x; then
+ case "$target_os" in
+ when(darwin*)
+ AC_MSG_CHECKING([for real target cpu])
+ target_cpu=`$CC -E - 2>/dev/null <<EOF |
+#ifdef __x86_64__
+"processor-name=x86_64"
+#endif
+#ifdef __i386__
+"processor-name=i386"
+#endif
+#ifdef __ppc__
+"processor-name=powerpc"
+#endif
+#ifdef __ppc64__
+"processor-name=powerpc64"
+#endif
+EOF
+ sed -n 's/^"processor-name=\(.*\)"/\1/p'`
+ AC_MSG_RESULT([$target_cpu])
+ ;;
+ esac
+ fi
target_archs="$target_cpu"
fi