summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-11-16 08:30:56 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-11-16 08:30:56 +0000
commit1c7f72dac2b864ceeccc6b6b871c6207340c8876 (patch)
treee39ad47495f25ce669543a5a4655f030e28a4adb /configure.in
parentc9b6a01435ef814f790f770520400e7f6ccc5e20 (diff)
configure.in: move after AC_PROG_CC
* configure.in (DTRACE): move after AC_PROG_CC since cross_compiling is set in it. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@37677 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index 504343af96..ee9ea8a112 100644
--- a/configure.in
+++ b/configure.in
@@ -373,14 +373,6 @@ if test x"${build}" != x"${host}"; then
AC_CHECK_TOOL(CC, gcc)
fi
-AC_CHECK_PROG([DTRACE], [${ac_tool_prefix}dtrace], [${ac_tool_prefix}dtrace])
-if test "$cross_compiling:$ac_cv_prog_DTRACE" = no: -a -n "$ac_tool_prefix"; then
- AC_CHECK_PROG([DTRACE], [dtrace], [dtrace])
-fi
-AS_CASE(["$target_os"],
-[freebsd*], [DTRACE=]
-)
-
AC_PROG_CC
AC_PROG_CXX
RUBY_MINGW32
@@ -396,6 +388,14 @@ else
linker_flag=
fi
+AC_CHECK_PROG([DTRACE], [${ac_tool_prefix}dtrace], [${ac_tool_prefix}dtrace])
+if test "$cross_compiling:$ac_cv_prog_DTRACE" = no: -a -n "$ac_tool_prefix"; then
+ AC_CHECK_PROG([DTRACE], [dtrace], [dtrace])
+fi
+AS_CASE(["$target_os"],
+[freebsd*], [DTRACE=]
+)
+
RUBY_PROG_GNU_LD
RUBY_CPPOUTFILE