summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-08-02 04:24:13 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-08-02 04:24:13 +0000
commit14bf66f25210248334f4730784ad00c18b7d651e (patch)
tree8f075350e3821cd476c859339cb112ce1951cf9a /configure.in
parentb79bf14ff26e11765c1605c7da9a3e72902c92d8 (diff)
* configure.in (AC_PROG_CC): AC_PROG_CC tries clang at first on
darwin. [Bug #6816] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@36594 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 27aed2f2ab..fad36e09d9 100644
--- a/configure.in
+++ b/configure.in
@@ -373,7 +373,9 @@ if test x"${build}" != x"${host}"; then
AC_CHECK_TOOL(CC, gcc)
fi
RUBY_MINGW32
-AC_PROG_CC
+AS_CASE(["$build_os"],
+[darwin*], [ AC_PROG_CC(clang gcc cc) ],
+ [ AC_PROG_CC ])
AC_PROG_CXX
AC_PROG_GCC_TRADITIONAL
AC_SUBST(GCC)