summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-05-07 04:41:02 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2012-05-07 04:41:02 +0000
commit0be8f819218c3244f011e52f26bdf41c69a993ed (patch)
tree5c225ec1084b6fe84e38d9886c50d6180b653afc /configure.in
parent9be3aa1767681caf5a441336eaf6408979a26649 (diff)
codesign
* Makefile.in (PROGRAM), configure.in (POSTLINK): sign built program using RUBY_CODESIGN identity. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@35559 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 18b5431068..70fedcf9b0 100644
--- a/configure.in
+++ b/configure.in
@@ -1059,6 +1059,11 @@ main()
if test "$rb_cv_broken_crypt" = yes; then
AC_DEFINE(BROKEN_CRYPT, 1)
fi
+ if test "${RUBY_CODESIGN:+set}"; then
+ AC_CHECK_PROGS(codesign, codesign)
+ POSTLINK="$ac_cv_prog_codesign -s '$RUBY_CODESIGN' -f \$@"
+ AC_SUBST(POSTLINK)
+ fi
],
[hpux*], [ LIBS="-lm $LIBS"
ac_cv_c_inline=no],