summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-02-18 21:21:02 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2013-02-18 21:21:02 +0000
commit0b261c379bddc9772321e1ca2a79e5073b6ee4b5 (patch)
treeb665a5c77cd55e1d125b0f2b0013335b24e1ba39 /configure.in
parente233ca15e02aeae3d6db60421bec5509d65991c6 (diff)
* vm_dump: FreeBSD ports' libexecinfo's backtrace(3) can't trace
beyond signal trampoline, and as described in r38342 it can't trace on -O because it see stack frame pointers. libunwind unw_backtrace see dwarf information in the binary and it works with -O (without frame pointers). * configure.in: remove r38342's hack and check libunwind. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@39302 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 1 insertions, 13 deletions
diff --git a/configure.in b/configure.in
index 669fb972da..e143053121 100644
--- a/configure.in
+++ b/configure.in
@@ -2417,19 +2417,7 @@ AS_CASE(["$target_cpu-$target_os"],
AC_CHECK_HEADERS([execinfo.h])
if test "x$ac_cv_header_execinfo_h" = xyes; then
AC_CHECK_LIB([execinfo], [backtrace])
- execinfo_frame_pointer=no
- RUBY_TRY_CFLAGS(-fno-omit-frame-pointer, [execinfo_frame_pointer=yes])
- if test "x$execinfo_frame_pointer" = xyes; then
- # optflags must be manipulated very carefully. For the
- # later cflagspat/cxxflagspat substitution to work, CFLAGS
- # and CXXFLAGS must start exactly with the value of
- # optflags.
- CFLAGS="${CFLAGS# }"; CFLAGS="${CFLAGS#"$optflags "}"
- CXXFLAGS="${CXXFLAGS# }"; CXXFLAGS="${CXXFLAGS#"$optflags "}"
- RUBY_APPEND_OPTION(optflags, -fno-omit-frame-pointer)
- CFLAGS=" $optflags $CFLAGS"
- CXXFLAGS=" $optflags $CXXFLAGS"
- fi
+ AC_CHECK_LIB([unwind], [unw_backtrace])
fi])
AC_CHECK_FUNCS(backtrace)