summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorshyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2007-09-07 07:38:51 +0000
committershyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2007-09-07 07:38:51 +0000
commit05f10eba96d36c10c38e9cee0697a0c105044010 (patch)
tree9a3cbdb53fe1a3d23508efbe503737cf130d9fe4 /configure.in
parent6f3d4a863a0514262fec5a5f8bc0538a49de00e0 (diff)
* configure.in (group_member): check if presents.
* configure.in (XCFLAGS): add _GNU_SOURCE on linux. * file.c (group_member): use system routine if available. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/branches/ruby_1_8_6@13393 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 29c19d2b0e..fc64335a06 100644
--- a/configure.in
+++ b/configure.in
@@ -537,7 +537,7 @@ AC_CHECK_FUNCS(fmod killpg wait4 waitpid syscall chroot fsync getcwd eaccess\
setproctitle setrgid setegid setregid setresgid issetugid pause\
lchown lchmod getpgrp setpgrp getpgid setpgid initgroups\
getgroups setgroups getpriority getrlimit setrlimit sysconf\
- dlopen sigprocmask\
+ group_member dlopen sigprocmask\
sigaction _setjmp setsid telldir seekdir fchmod mktime timegm\
cosh sinh tanh setuid setgid setenv unsetenv)
AC_ARG_ENABLE(setreuid,
@@ -1401,6 +1401,9 @@ fi
AC_SUBST(RDOCTARGET)
case "$target_os" in
+ linux*)
+ XCFLAGS="$XCFLAGS -D_GNU_SOURCE=1"
+ ;;
netbsd*)
CFLAGS="$CFLAGS -pipe"
;;