summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-04-06 17:47:33 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-04-06 17:47:33 +0000
commit04d1fc84b47eedef3a3036afe89749116467481a (patch)
tree095dbcb9c6b1a0585e40f8f330a903650aef2e6e /configure.in
parentc30f5e82a7330ec714d6fd7e3b3ff7b9212fcc0f (diff)
* configure.in (RUBY_DEFINT): use AC_INCLUDES_DEFAULT.
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@23147 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 7a7b4f6187..9c93bd9ae1 100644
--- a/configure.in
+++ b/configure.in
@@ -981,8 +981,8 @@ typedef $1 t; int s = sizeof(t) == 42;])],
if test "${rb_cv_type_$1}" != no; then
AC_DEFINE([HAVE_]AS_TR_CPP($1), 1)
if test "${rb_cv_type_$1}" = yes; then
- m4_bmatch([$2], [^[1-9][0-9]*$], [AC_CHECK_SIZEOF([$1], 0, [$4])],
- [RUBY_CHECK_SIZEOF([$1], [$2], [], [$4])])
+ m4_bmatch([$2], [^[1-9][0-9]*$], [AC_CHECK_SIZEOF([$1], 0, [AC_INCLUDES_DEFAULT([$4])])],
+ [RUBY_CHECK_SIZEOF([$1], [$2], [], [AC_INCLUDES_DEFAULT([$4])])])
else
AC_DEFINE_UNQUOTED($1, [$rb_cv_type_$1])
AC_DEFINE_UNQUOTED([SIZEOF_]AS_TR_CPP($1), [SIZEOF_]AS_TR_CPP([$rb_cv_type_$1]))