summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-05-21 02:42:33 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2014-05-21 02:42:33 +0000
commit003710957b63dafda7535aa84df10b0a2b5ae00e (patch)
treef1d84a8605e05fd5a8177ca9485282adcbe02ac7 /configure.in
parent7bf10e8787912565c53bb774e7508c2955515326 (diff)
configure.in: Info.plist workaround
* configure.in: workaround for Info.plist to get rid of `dsymutil` crash by wrong files in parent directories. [ruby-core:62594] [Bug #9840] git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@46032 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 6b14d21db1..97e95eeb52 100644
--- a/configure.in
+++ b/configure.in
@@ -691,13 +691,22 @@ RUBY_WERROR_FLAG([
]
)
AC_MSG_CHECKING([whether LDFLAGS is valid])
+ {
+ mkdir tmp.$$.try_link &&
+ cd tmp.$$.try_link &&
+ cp ../confdefs.h . &&
+ echo '<?xml?><plist><dict><key>CFBundleIdentifier</key><string></string></dict></plist>' > Info.plist &&
+ :
+ } || AC_MSG_ERROR([faild to make temporary directory])
AC_TRY_LINK([], [],
[AC_MSG_RESULT(yes)],
[
+ cd .. && rm -fr tmp.$$.try_link
AC_MSG_RESULT(no)
AC_MSG_ERROR([something wrong with LDFLAGS="$LDFLAGS"])
]
)
+ cd .. && rm -fr tmp.$$.try_link
])
AC_DEFUN(RUBY_TRY_CFLAGS, [