summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRick Mark <rick.mark@coinbase.com>2021-03-19 15:27:42 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2021-03-19 15:27:42 +0900
commitdc7044eb48f475e5ac34e994e89115052574c451 (patch)
treea2f8042065c37c742e1b48c455284c95c8d934ff /configure.ac
parent4ea96f1d4f8a50c204c4367c994cdbf12cd97b64 (diff)
Remove unneeded dependencies on macOS [Feature #17730]
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/4289
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 83eee92e94..f894008212 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3641,8 +3641,8 @@ AS_CASE(["$target_os"],
RUBY_APPEND_OPTION(LIBRUBYARG_STATIC, [-framework Security])
]dnl
)
- RUBY_APPEND_OPTION(XLDFLAGS, [-framework Foundation])
- RUBY_APPEND_OPTION(LIBRUBYARG_STATIC, [-framework Foundation])
+ RUBY_APPEND_OPTION(XLDFLAGS, [-framework CoreFoundation])
+ RUBY_APPEND_OPTION(LIBRUBYARG_STATIC, [-framework CoreFoundation])
],
[osf*], [
AS_IF([test "$GCC" != "yes" ], [