summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2021-03-19 15:23:03 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2021-03-19 15:23:03 +0900
commit4ea96f1d4f8a50c204c4367c994cdbf12cd97b64 (patch)
tree2a62d8197c6ab29b376ebad61ce7f9a852d37c9a /configure.ac
parenta85ed626f18d1014d09fb37eb0a703976c3d2b53 (diff)
Use CommonRandom if available
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/4289
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0110896e4a..83eee92e94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3634,7 +3634,8 @@ AS_CASE(["$target_os"],
RUBY_APPEND_OPTION(CFLAGS, -pipe)
AC_COMPILE_IFELSE([
AC_LANG_BOOL_COMPILE_TRY([@%:@include <AvailabilityMacros.h>],
- [MAC_OS_X_VERSION_MIN_REQUIRED >= MAC_OS_X_VERSION_10_7])],
+ [MAC_OS_X_VERSION_MIN_REQUIRED >= MAC_OS_X_VERSION_10_7 &&
+ MAC_OS_X_VERSION_MIN_REQUIRED < MAC_OS_X_VERSION_10_10])],
[dnl
RUBY_APPEND_OPTION(XLDFLAGS, [-framework Security])
RUBY_APPEND_OPTION(LIBRUBYARG_STATIC, [-framework Security])