summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
author卜部昌平 <shyouhei@ruby-lang.org>2020-04-09 16:25:17 +0900
committer卜部昌平 <shyouhei@ruby-lang.org>2020-04-10 16:17:30 +0900
commit75802bcff1b941818832f0145071f7ce9c843d8d (patch)
tree6a7a24531ead1301f088e2c13f044707a3ab8eba /configure.ac
parente43237b115e648d69b5035c196851fb4a98698d8 (diff)
configure: suppress icc warnings
Every time a pointer to/from VALUE conversion happens, these two warnings are issued: - warning #1684: conversion from pointer to same-sized integral type (potential portability problem) - warning #2312: pointer cast involving 64-bit pointed-to type Thank you, but we are well aware of the "potential portability problem". Let us ignore them all.
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/3011
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d9e40b0591..9c2cb14173 100644
--- a/configure.ac
+++ b/configure.ac
@@ -549,7 +549,7 @@ AS_CASE(["$GCC:${warnflags+set}:${extra_warnflags:+set}:"],
-Wsuggest-attribute=format \
-Wsuggest-attribute=noreturn \
-Wunused-variable \
- -diag-disable=175,188,2259 \
+ -diag-disable=175,188,1684,2259,2312 \
$extra_warnflags \
; do
AS_IF([test "$particular_werror_flags" != yes], [