summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
author卜部昌平 <shyouhei@ruby-lang.org>2020-04-10 10:19:39 +0900
committer卜部昌平 <shyouhei@ruby-lang.org>2020-04-10 16:17:30 +0900
commite43237b115e648d69b5035c196851fb4a98698d8 (patch)
treed94dcfb7da80992be47b4dfa75df18560c69eddc /configure.ac
parent133ae0807d661eac174b59c6e91c11a40975baea (diff)
configure: always check for __builtin_unreachable
Non-gcc compilers tend to have this intrinsic these days (e.g. icc). Better check it regardless of $GCC.
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/3011
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2d200a3235..d9e40b0591 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1520,6 +1520,7 @@ AS_IF([test "$GCC" = yes], [
AS_IF([test "$rb_cv_gcc_sync_builtins" = yes], [
AC_DEFINE(HAVE_GCC_SYNC_BUILTINS)
])
+])
AC_CACHE_CHECK(for __builtin_unreachable, rb_cv_func___builtin_unreachable,
[RUBY_WERROR_FLAG(
@@ -1532,7 +1533,6 @@ AS_IF([test "$GCC" = yes], [
AS_IF([test "$rb_cv_func___builtin_unreachable" = yes], [
AC_DEFINE_UNQUOTED(UNREACHABLE, [__builtin_unreachable()])
])
-])
AC_CACHE_CHECK(for exported function attribute, rb_cv_func_exported, [
rb_cv_func_exported=no