summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2019-05-25 17:20:31 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2019-05-25 17:20:31 +0900
commit65ce14e7b5f66a92f452136290357eb3df147e5b (patch)
tree2b94074a2c72ae1dda1a853f3aa255dfbac9dd56 /configure.ac
parent4fae3c3fb0847ba8eccb61b3c0cc0ae874c17cf0 (diff)
Added --with-rdoc option
New option to direct formats of RDoc to install.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 14 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d7b575ba18..34026ce325 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3321,18 +3321,30 @@ CAPITARGET=""
AC_ARG_ENABLE(install-doc,
AS_HELP_STRING([--disable-install-doc], [do not install either rdoc indexes or C API documents during install]),
[install_doc=$enableval], [install_doc=yes])
+AC_ARG_WITH(rdoc,
+ AS_HELP_STRING([--with-rdoc=ri,html], [comma/space separated list of RDoc formats to install]),
+ [install_rdoc=`echo ,$withval, | sed 'y/,/ /;s/ ri / rdoc /;s/^ *//;s/ *$//'`], [
AC_ARG_ENABLE(install-rdoc,
AS_HELP_STRING([--disable-install-rdoc], [do not install rdoc indexes during install]),
[install_rdoc=$enableval], [install_rdoc=yes])
+])
AC_ARG_ENABLE(install-capi,
AS_HELP_STRING([--disable-install-capi], [do not install C API documents during install]),
[install_capi=$enableval], [install_capi=no])
AS_IF([test "$install_doc" != no], [
- AS_IF([test "$install_rdoc" != no], [
+ AS_CASE(["$install_rdoc"],
+ [yes], [
RDOCTARGET="rdoc"
- ], [
+ ],
+ [all], [
+ RDOCTARGET="rdoc html"
+ ],
+ [no|''], [
RDOCTARGET="nodoc"
+ ],
+ [
+ RDOCTARGET="$install_rdoc"
])
AS_IF([test "$install_capi" != no -a -n "$DOXYGEN"], [
CAPITARGET="capi"