summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2019-05-25 16:56:26 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2019-05-25 17:16:07 +0900
commit4fae3c3fb0847ba8eccb61b3c0cc0ae874c17cf0 (patch)
treea44186d493d6462cbad2ff3779b3ef7f9eca4a81 /configure.ac
parent8fd3b9fc5f0f0ef031c54982236b6da327b81458 (diff)
Show doc list to install
Show document format list to install, not only enabled or disable.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d068efddd4..d7b575ba18 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3992,6 +3992,9 @@ AS_REQUIRE_SHELL_FN([config_summary],
])]
)
+AS_IF([test $install_doc = yes],
+ [DOCTARGETS=`echo " $RDOCTARGET $CAPITARGET " | sed 's/ nodoc //g;s/^ *//;s/ *$//'`],
+ [DOCTARGETS=no])
echo "---"
echo "Configuration summary for $RUBY_BASE_NAME version $MAJOR.$MINOR.$TEENY"
echo ""
@@ -4017,7 +4020,7 @@ config_summary "optflags" "$optflags"
config_summary "debugflags" "$debugflags"
config_summary "warnflags" "$warnflags"
config_summary "strip command" "$STRIP"
-config_summary "install doc" "$install_doc"
+config_summary "install doc" "$DOCTARGETS"
config_summary "JIT support" "$MJIT_SUPPORT"
config_summary "man page type" "$MANTYPE"
config_summary "search path" "$search_path"