summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenoit Daloze <eregontp@gmail.com>2021-07-29 22:11:19 +0200
committerBenoit Daloze <eregontp@gmail.com>2021-07-29 22:11:19 +0200
commit15d05f8120745a121b93fab9fd2addf5f094e8d2 (patch)
tree5650659c90ed5243a70486eb0e22803a2f697c40
parent41e2ab88c3722a7de7c5bbe189754d32a83bc52e (diff)
Update to ruby/mspec@9542a88
-rw-r--r--spec/mspec/README.md2
-rw-r--r--spec/mspec/lib/mspec/utils/script.rb4
2 files changed, 3 insertions, 3 deletions
diff --git a/spec/mspec/README.md b/spec/mspec/README.md
index e334d56972b..94ab608031b 100644
--- a/spec/mspec/README.md
+++ b/spec/mspec/README.md
@@ -36,7 +36,7 @@ specs in a manner compatible with multiple Ruby implementations.
## Requirements
-MSpec requires Ruby 2.5 or more recent.
+MSpec requires Ruby 2.6 or more recent.
## Bundler
diff --git a/spec/mspec/lib/mspec/utils/script.rb b/spec/mspec/lib/mspec/utils/script.rb
index 5c6ae70e5d7..a77476ee2e9 100644
--- a/spec/mspec/lib/mspec/utils/script.rb
+++ b/spec/mspec/lib/mspec/utils/script.rb
@@ -280,8 +280,8 @@ class MSpecScript
end
private def check_version!
- ruby_version_is ""..."2.5" do
- warn "MSpec is supported for Ruby 2.5 and above only"
+ ruby_version_is ""..."2.6" do
+ warn "MSpec is supported for Ruby 2.6 and above only"
end
end
end