summaryrefslogtreecommitdiff
path: root/.travis.yml
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2020-02-08 19:43:27 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2020-04-01 15:36:20 +0900
commit826f44834fe11f3f9c52343443a15b6c83466889 (patch)
treef2c2abed62db1c750515cd8b0fbac6442b6d4200 /.travis.yml
parent3a2073e61b6ccce6d07d31ebd89d4c385b9a55f2 (diff)
Drop support for ruby 2.4 from ruby/spec
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/2892
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml10
1 files changed, 5 insertions, 5 deletions
diff --git a/.travis.yml b/.travis.yml
index e26fe1d..1bd1ce8 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -360,17 +360,17 @@ env:
-Wunused-variable'
- LDFLAGS=-Wno-unused-command-line-argument
- - &rubyspec24
- name: Check ruby/spec version guards on Ruby 2.4
+ - &rubyspec25
+ name: Check ruby/spec version guards on Ruby 2.5
language: ruby
- rvm: 2.4.9
+ rvm: 2.5.7
before_install:
install:
before_script: chmod -R u+w spec/ruby
# -j randomly hangs.
script: ruby -C spec/ruby ../mspec/bin/mspec .
after_failure:
- - echo "ruby/spec failed on Ruby 2.4. This is likely because of a missing ruby_version_is guard, please add it. See spec/README.md."
+ - echo "ruby/spec failed on Ruby 2.5. This is likely because of a missing ruby_version_is guard, please add it. See spec/README.md."
- &rubyspec27
name: Check ruby/spec version guards on Ruby 2.7
@@ -435,7 +435,7 @@ matrix:
- <<: *pedanticism
- <<: *assertions
- <<: *baseruby
- - <<: *rubyspec24
+ - <<: *rubyspec25
- <<: *rubyspec27
- <<: *dependency
# Build every commit (Allowed Failures):