summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a299c766b2..4bb27580f7 100644
--- a/configure.in
+++ b/configure.in
@@ -72,6 +72,7 @@ if test "$program_prefix" = NONE; then
program_prefix=
fi
AC_CANONICAL_TARGET
+target_os=`echo $target_os | sed 's/linux-gnu$/linux/;s/linux-gnu/linux-/'`
dnl checks for fat-binary
AC_ARG_ENABLE(fat-binary,
@@ -778,7 +779,6 @@ case "$target_os" in
linux*)
if test "$rb_cv_binary_elf" = no; then
with_dln_a_out=yes
- target_os=${target_os}-a_out
else
LDFLAGS="$LDFLAGS -rdynamic"
fi;;