summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2696d6e76c..e20e133feb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1930,7 +1930,14 @@ AC_DEFUN([RUBY_REQUIRE_FUNC], [
AS_IF([test "$ac_cv_func_[]AS_TR_SH($1)" = yes], [],
[AC_MSG_ERROR($1[() must be supported])])
])
-m4_map_args_w([dup dup2], [RUBY_REQUIRE_FUNC(], [)])
+
+# dup and dup2 are always available except for WASI
+AS_CASE(["$target_os"],
+ [wasi*], [],
+ [
+ m4_map_args_w([dup dup2], [RUBY_REQUIRE_FUNC(], [)])
+ ]
+)
AC_REPLACE_FUNCS(acosh)
AC_REPLACE_FUNCS(cbrt)