summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4c250d4d75..d6a4169802 100644
--- a/configure.ac
+++ b/configure.ac
@@ -404,10 +404,12 @@ AS_IF([test "$GCC" = yes], [
: ${optflags=-O3}
gcc_major=`echo =__GNUC__ | $CC -E -xc - | sed '/^=/!d;s///'`
gcc_minor=`echo =__GNUC_MINOR__ | $CC -E -xc - | sed '/^=/!d;s///'`
- icc_version=`echo =__ICC | $CC -E -xc - | sed '/^=/!d;s///'`
test -n "$gcc_major" || gcc_major=0
test -n "$gcc_minor" || gcc_minor=0
- test -n "$icc_version" || icc_version=0
+ AS_CASE(["x$CC"], [xicc], [
+ icc_version=`echo =__ICC | $CC -E -xc - | sed '/^=/!d;s///'`
+ test -n "$icc_version" || icc_version=0
+ ])
# RUBY_APPEND_OPTIONS(XCFLAGS, ["-include ruby/config.h" "-include ruby/missing.h"])
], [
linker_flag=