summaryrefslogtreecommitdiff
path: root/tool/install-sh
diff options
context:
space:
mode:
authoryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-12-28 04:20:19 +0000
committeryugui <yugui@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2009-12-28 04:20:19 +0000
commitd4c2172e02ddda417ee3679e97e88827e70fd00c (patch)
treecaef6b46b4242489b7d4364c8789b36c3972196a /tool/install-sh
parentb3c318bffd951d7ea4b35bbc2a3c8d6c6d190716 (diff)
* tool/install-sh: wrote the intention. [ruby-dev:39928]
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@26185 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'tool/install-sh')
-rw-r--r--[-rwxr-xr-x]tool/install-sh17
1 files changed, 17 insertions, 0 deletions
diff --git a/tool/install-sh b/tool/install-sh
index e69de29..a5d1185 100755..100644
--- a/tool/install-sh
+++ b/tool/install-sh
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+# Just only for using AC_PROG_INSTALL in configure.in.
+# See autoconf.info for more detail.
+
+cat <<EOF >&2
+Ruby tries to use a BSD-compatible install(1) if possible. However Ruby
+has its own install(1) alternative.
+
+This script is necessary just for using AC_PROG_INSTALL in configure.in,
+however, it will not executed. So this script just fails.
+Please report a bug of Ruby to http://redmine.ruby-lang.org if you meet
+this message.
+
+Thank you.
+EOF
+exit 1