summaryrefslogtreecommitdiff
path: root/ext/openssl
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-07-29 08:13:05 (GMT)
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-07-29 08:13:05 (GMT)
commit01d81d19915eb931773e095c2aee46c16c441e23 (patch)
tree0738a0e78900cbfe124d45bb917be8db8c5a9ffc /ext/openssl
parente3c1c406fc2bf6c4c2d7308562214b00fd9f7ca1 (diff)
reduce LibreSSL warnings
* ext/openssl/extconf.rb: LibreSSL headers emit "overriding WinCrypt defines" warnings if wincrypt.h has been included (except for x509.h) on Windows. get rid of including the header by defining NOCRYPT macro. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@64101 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'ext/openssl')
-rw-r--r--ext/openssl/extconf.rb4
1 files changed, 4 insertions, 0 deletions
diff --git a/ext/openssl/extconf.rb b/ext/openssl/extconf.rb
index 8d705f3..cefa295 100644
--- a/ext/openssl/extconf.rb
+++ b/ext/openssl/extconf.rb
@@ -114,6 +114,10 @@ engines.each { |name|
OpenSSL.check_func_or_macro("ENGINE_load_#{name}", "openssl/engine.h")
}
+if ($mswin || $mingw) && have_macro("LIBRESSL_VERSION_NUMBER")
+ $defs.push("-DNOCRYPT")
+end
+
# added in 1.0.2
have_func("EC_curve_nist2nid")
have_func("X509_REVOKED_dup")