summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKenta Murata <3959+mrkn@users.noreply.github.com>2022-09-14 22:17:39 +0900
committerGitHub <noreply@github.com>2022-09-14 22:17:39 +0900
commitf512df73986c74e2f4bd65ca642879a0618da213 (patch)
tree146b4af30f58d9c7a822655b8411958ce9afb911 /configure.ac
parent075df960c93cb2d3ebe308f67871f39565b4426e (diff)
configure.ac: Add --with-gmp-dir (#6366)
Add the `--with-gmp-dir` to specify the prefix directory of GMP. The`--without-gmp` option is preserved for convenience. It can be used to force to reject using GMP even if the `--with-gmp-dir` option is specified.
Notes
Notes: Merged-By: mrkn <mrkn@ruby-lang.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 9 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 2595c6ee6a..92b1a6a696 100644
--- a/configure.ac
+++ b/configure.ac
@@ -930,6 +930,15 @@ AS_CASE(["$target_cpu"], [[i[3-6]86*]], [
])
OPT_DIR=
+AC_ARG_WITH([gmp-dir],
+ AS_HELP_STRING([--with-gmp-dir=DIR],
+ [specify the prefix directory where gmp is installed]),
+ [OPT_DIR="$withval"], [])
+AC_ARG_WITH([gmp],
+ [AS_HELP_STRING([--without-gmp],
+ [disable GNU GMP to accelerate Bignum operations])],
+ [OPT_DIR=], [with_gmp=yes])
+
AC_ARG_WITH(opt-dir,
AS_HELP_STRING([--with-opt-dir=DIR-LIST],
[add optional headers and libraries directories separated by $PATH_SEPARATOR]),
@@ -1319,11 +1328,6 @@ AS_CASE("$target_cpu", [x64|x86_64|i[3-6]86*], [
])
RUBY_UNIVERSAL_CHECK_HEADER([x86_64, i386], x86intrin.h)
-AC_ARG_WITH([gmp],
- [AS_HELP_STRING([--without-gmp],
- [disable GNU GMP to accelerate Bignum operations])],
- [],
- [with_gmp=yes])
AS_IF([test "x$with_gmp" != xno],
[AC_CHECK_HEADERS(gmp.h)
AS_IF([test "x$ac_cv_header_gmp_h" != xno],