summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorshyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-02-06 02:08:13 +0000
committershyouhei <shyouhei@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-02-06 02:08:13 +0000
commiteb537609ba0de060c6633dc3e7dd9ba5e85c6d1b (patch)
treecb3d89826021f803594adeaf7e96699da371c33a /configure.ac
parent1f003810c22ca758bcf9c83b2f1f4755d74c47e1 (diff)
deal with aclocal(1)
This commit updates files so that aclocal.m4 generated by aclocal(1) works well with our configure.ac * ac_checking.m4: merged back to configure.ac because aclocal(1) cannot handle this macro. * ruby_append_options.m4: no longer used. * ruby_check_va_copy.m4: define using AC_DEFUN so that aclocal(1) can find this macro. git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@62243 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a09b5def03..79a0bebb93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,6 +6,13 @@ AC_CONFIG_MACRO_DIRS(tool/m4)
AC_PREREQ(2.67)
+dnl override AC_CHECKING
+dnl placed here due to aclocal(1)'s
+dnl ignoring this definition in separate files
+AC_DEFUN([AC_CHECKING],[dnl
+AC_REQUIRE([_COLORIZE_RESULT_PREPARE])dnl
+AS_MESSAGE([checking ${msg_checking}$1${msg_reset}...])])dnl
+
AC_DISABLE_OPTION_CHECKING
AC_ARG_VAR([cflags], [additional CFLAGS])