summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNaohisa Goto <ngotogenome@gmail.com>2021-11-30 14:23:07 +0900
committerNaohisa Goto <ngotogenome@gmail.com>2021-11-30 16:39:31 +0900
commite59f3054c308fc657224d2dde8d100816b82de84 (patch)
treef4ae1763aa3db654a164e0bbc03a8a7cbd16e55e /configure.ac
parent438220f063c939761e3d85f7e307c321474c84e8 (diff)
Delete #if line during checking madvise() on Solaris
The madvise() declaration should always be compiled on Solaris to check whether the declaration is good on the environment. For the purpose, the #if line is unnecessary. (There was also a trivial typo that the #if was not closed by #endif and the check always failed with preprocessor error.)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 0 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bb58fad089..0f7c0d5477 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1110,7 +1110,6 @@ main()
AC_CHECK_TYPES([caddr_t],[],[],[@%:@include <sys/types.h>])
AC_CACHE_CHECK([whether madvise declaration is needed], rb_cv_madvice_prototype_using_caddr_t,
[RUBY_WERROR_FLAG([AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
- @%:@if defined(HAVE_CADDR_T) && (defined(MADV_FREE) || defined(MADV_DONTNEED))
@%:@include <sys/unistd.h>
@%:@include <sys/mman.h>
@%:@include <sys/types.h>