summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYusuke Endoh <mame@ruby-lang.org>2020-04-09 08:55:46 +0900
committerYusuke Endoh <mame@ruby-lang.org>2020-04-09 08:55:46 +0900
commitcdd613b2997944cd0d82f8d41071440779c19a99 (patch)
treed5b3c462daf90227bcef00853c1ee11eec33bc11 /configure.ac
parent8ab4c55e7a70f5a5bd041d93f425eeef4a47c01e (diff)
configure.ac: Skip C++ compiler of Sun OpenStudio
It fails to compile ext/-test-/cxxanyargs/cxxanyargs.cpp. Need work to support it. Contribution is welcome.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bd752d93d3..2d200a3235 100644
--- a/configure.ac
+++ b/configure.ac
@@ -219,6 +219,11 @@ AS_CASE(["$build_os:${CXX}"],
AC_MSG_RESULT([$CXX])],
[openbsd*:*], [
AC_CHECK_TOOLS(CXX, [c++])
+ ],
+ [solaris*:*], [
+ dnl C++ compiler of Sun OpenStudio is not supported
+ AS_CASE(["/$CC "],
+ [*@<:@\ /@:>@"cc "*], [CXX=no-c++])
])
test -z "$CXX" || ac_cv_prog_CXX="$CXX"