summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authork0kubun <k0kubun@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-11-19 14:00:49 +0000
committerk0kubun <k0kubun@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-11-19 14:00:49 +0000
commitb756b25c60a887d5d073db7ccbb5e214b5cfd939 (patch)
tree38c24760be5fe81e725c66e2ebeb4df487c37d99 /configure.ac
parent83aff333cdd1a36b8dbb6a3903e047b1304fa1ae (diff)
ruby.c: do not surface MJIT to user
In some places, both JIT and MJIT are being used, but it could be confusing for new comers. We're not explaining MJIT on NEWS file or release notes as well. So we consider MJIT as an internal term of implementation like YARV. configure.ac: ditto git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@65810 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 2512e85cba..2c9b5de6fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3341,10 +3341,10 @@ AC_SUBST(CAPITARGET)
AS_CASE(["$RDOCTARGET:$CAPITARGET"],[nodoc:nodoc],[INSTALLDOC=nodoc],[INSTALLDOC=all])
AC_SUBST(INSTALLDOC)
-AC_ARG_ENABLE(mjit-support,
- AS_HELP_STRING([--disable-mjit-support], [disable MJIT features]),
+AC_ARG_ENABLE(jit-support,
+ AS_HELP_STRING([--disable-jit-support], [disable JIT features]),
[MJIT_SUPPORT=$enableval
- AS_IF([test x"$enable_mjit_support" = "xyes"],
+ AS_IF([test x"$enable_jit_support" = "xyes"],
[AC_DEFINE(USE_MJIT, 1)],
[AC_DEFINE(USE_MJIT, 0)])],
[MJIT_SUPPORT=yes
@@ -4016,7 +4016,7 @@ config_summary "debugflags" "$debugflags"
config_summary "warnflags" "$warnflags"
config_summary "strip command" "$STRIP"
config_summary "install doc" "$install_doc"
-config_summary "MJIT support" "$MJIT_SUPPORT"
+config_summary "JIT support" "$MJIT_SUPPORT"
config_summary "man page type" "$MANTYPE"
config_summary "search path" "$search_path"
config_summary "static-linked-ext" ${EXTSTATIC:+"yes"}