summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
author卜部昌平 <shyouhei@ruby-lang.org>2021-07-07 17:50:11 +0900
committer卜部昌平 <shyouhei@ruby-lang.org>2021-07-07 20:31:20 +0900
commit82d425515d2c1a14f964fc7a571e272f933bba7a (patch)
treedd2d3e3f015c63c99f9da430bd6c3a814875a76a /configure.ac
parent737e4432b978eb4b9f5b10fb6cc6d9c883a5d17a (diff)
comment about the situation [ci skip]
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/4631
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9ce7538aae..4f669db8a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3383,6 +3383,12 @@ AS_CASE("$enable_shared", [yes], [
AC_DEFINE_UNQUOTED(LIBDIR_BASENAME, ["${libdir_basename}"])
libdir_basename="${libdir_basename}"${multiarch+'/${arch}'}
+ # Debian bullseye reportedly has its ld(1) patched, which breaks
+ # --enable-shared --with-jemalloc combination. We might have to deal with
+ # the ld(1) change sooner or later, but in the meantime let us force it
+ # the old way.
+ #
+ # See https://github.com/ruby/ruby/pull/4627
RUBY_TRY_LDFLAGS([${linker_flag}--no-as-needed], [no_as_needed=yes], [no_as_needed=no])
AS_IF([test "$no_as_needed" = yes], [
RUBY_APPEND_OPTIONS(LDFLAGS, [${linker_flag}--no-as-needed])