summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2021-08-27 12:42:23 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2021-08-27 12:42:23 +0900
commit80c1faf0769abfb459c5c749206ed02311d8274b (patch)
tree0d3f032106e6a6061d21903e0e42598e7bc34baa /configure.ac
parent04be8e84db1cf4f8b2a7bc7679eda4336da75d43 (diff)
Use C99-defined signbit macro
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/4783
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 1 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 900967492d..beb352dbe9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1916,17 +1916,7 @@ AS_CASE(["$target_os"],
AC_CHECK_HEADERS(sys/pstat.h)
-AC_CACHE_CHECK(for signbit, rb_cv_have_signbit,
- [AC_LINK_IFELSE([AC_LANG_PROGRAM([[
-#include <math.h>
-]], [[int v = signbit(-0.0);]])],
- rb_cv_have_signbit=yes,
- rb_cv_have_signbit=no)])
-AS_IF([test "$rb_cv_have_signbit" = yes], [
- AC_DEFINE(HAVE_SIGNBIT)
-], [
- AC_LIBOBJ([signbit])
-])
+AC_DEFINE(HAVE_SIGNBIT) # C99; backward compatibility
AC_FUNC_FORK