summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authornaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-12-10 13:58:36 +0000
committernaruse <naruse@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-12-10 13:58:36 +0000
commit7405bbda27a60f2c06af10f2ab49e5b15b043274 (patch)
treee493afd6f477cbd44fe40e2607662882f3a9cad2 /configure.ac
parent8bb7c992b84e104e7ec8c3fe7a9d32c367efaef6 (diff)
Define HAVE_STMT_AND_DECL_IN_EXPR and use it [Bug #15293]
git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@66311 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d562b16b6f..3b740e0ff5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -730,6 +730,13 @@ test -z "${ac_env_CFLAGS_set}" -a -n "${cflags+set}" && eval CFLAGS="\"$cflags $
test -z "${ac_env_CXXFLAGS_set}" -a -n "${cxxflags+set}" && eval CXXFLAGS="\"$cxxflags $ARCH_FLAG\""
}
+AC_PREPROC_IFELSE([AC_LANG_SOURCE([[
+ int main(void) {
+ return __extension__ ({ int a = 0; a; });
+ }
+ ]])],
+ [AC_DEFINE(HAVE_STMT_AND_DECL_IN_EXPR, 1)])
+
: "header and library section" && {
AC_ARG_WITH(winnt-ver,
AS_HELP_STRING([--with-winnt-ver=0xXXXX], [target Windows NT version (default to 0x0600)]),