summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2020-09-28 13:05:21 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2020-09-28 13:42:04 +0900
commit67ae1d441dbc2d944a08b95178f99d2cf67169e1 (patch)
tree8bb8a777359609c4ddd1a2dcf4787e9c9f78131f /configure.ac
parent36d1bb720c72eba2a3574a4ea721ed8a6207d39f (diff)
Do not use clang on cygwin
Its `__has_declspec_attribute()` is not reliable. For instance, while `__has_declspec_attribute(noalias)` is true but 'noalias' attribute is warned as unknown.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f7bbc36366..16e6457ce2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,7 +101,7 @@ AS_IF([test ! -z "$ac_cv_prog_CC" -a ! -z "$CC" -a "$CC" != "$ac_cv_prog_CC"], [
AC_MSG_ERROR(cached CC is different -- throw away $cache_file
(it is also a good idea to do 'make clean' before compiling))
])
-AS_CASE(["${build_os}"], [linux*], [
+AS_CASE(["${build_os}"], [linux*|cygwin*], [
AC_CHECK_TOOLS([CC], [gcc clang cc])
], [
# OpenBSD wants to prefer cc over gcc.