summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2020-04-05 10:56:28 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2020-04-05 10:56:28 +0900
commit4f938ffa35f5770af73d55e679f9524e032cbfc3 (patch)
tree61606235d924daeb42f7e7dbe37ea3c6d644e11a /configure.ac
parent4a6571dbc14ee4e88c12cd9931f7695077a3ee6e (diff)
Use toodir also in configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b1a7797f33..9544e45620 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,6 +6,8 @@ AC_CONFIG_MACRO_DIRS(tool/m4)
AC_PREREQ(2.67)
+tooldir="$srcdir/tool"
+
dnl override AC_CHECKING
dnl placed here due to aclocal(1)'s
dnl ignoring this definition in separate files
@@ -294,7 +296,7 @@ AS_CASE(["$build_os"],
echo 'int main(void) {return 0;}' > conftest.c
AS_IF([$CC -framework Foundation -o conftest conftest.c 2>&1 |
grep '^ld: warning: text-based stub file' >/dev/null], [
- CC_WRAPPER=`cd -P "$srcdir/tool" && pwd`/darwin-cc
+ CC_WRAPPER=`cd -P "${tooldir}" && pwd`/darwin-cc
CC="$CC_WRAPPER $CC"
])
rm -fr conftest*
@@ -3949,7 +3951,7 @@ guard=INCLUDE_RUBY_CONFIG_H
} | tr -d '\015' |
(
AS_IF([test "x$CONFIGURE_TTY" = xyes], [color=--color], [color=])
- exec ${srcdir}/tool/ifchange $color "${config_h}" -
+ exec ${tooldir}/ifchange $color "${config_h}" -
) >&AS_MESSAGE_FD || AC_MSG_ERROR([failed to create ${config_h}])
tr -d '\015' < largefile.h > confdefs.h
rm largefile.h