summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2021-07-07 10:35:15 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2021-07-07 23:40:04 +0900
commit372d94b6ba73d85b2c63c70e873a4914bbe9dbad (patch)
tree26f4b3761cc7088771b99ebd143eed74e6f3f977 /configure.ac
parente8d953937388e498f9850f72d9d930962381a10b (diff)
Shared libruby also needs MAINLIBS for jemalloc
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/4632
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 78a0662ed2..d018e8a6f4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3869,6 +3869,7 @@ AS_IF([test -n "${LIBS}"], [
MAINFLAGS=`echo " $MAINLIBS " | sed "s|$libspat"'||;s/^ *//;s/ *$//'`
])
LIBRUBYARG_STATIC="${LIBRUBYARG_STATIC} \$(MAINLIBS)"
+LIBRUBYARG_SHARED="${LIBRUBYARG_SHARED} \$(MAINLIBS)"
CPPFLAGS="$CPPFLAGS "'$(DEFS)'
test -z "$CPPFLAGS" || CPPFLAGS="$CPPFLAGS "; CPPFLAGS="$CPPFLAGS"'${cppflags}'
AS_IF([test -n "${cflags+set}"], [