summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKenta Murata <3959+mrkn@users.noreply.github.com>2022-09-14 21:20:32 +0900
committerKenta Murata <mrkn@mrkn.jp>2022-09-14 23:14:36 +0900
commit2e25b85a7e4268676fcdf17b5975c2fd60066ce1 (patch)
treea4e9b002101484928f6f70936d1b62e2c0bd5bf1 /configure.ac
parent960db13c472773926dc8c3dec8ba62d60aaa77f9 (diff)
configure.ac: Apply suggestions from code review in #6366
Co-authored-by: Nobuyoshi Nakada <nobu@ruby-lang.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 92b1a6a696..43f1541f3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -933,11 +933,11 @@ OPT_DIR=
AC_ARG_WITH([gmp-dir],
AS_HELP_STRING([--with-gmp-dir=DIR],
[specify the prefix directory where gmp is installed]),
- [OPT_DIR="$withval"], [])
+ [OPT_DIR="${OPT_DIR:+$OPT_DIR$PATH_SEPARATOR}$withval"], [])
AC_ARG_WITH([gmp],
[AS_HELP_STRING([--without-gmp],
[disable GNU GMP to accelerate Bignum operations])],
- [OPT_DIR=], [with_gmp=yes])
+ [], [with_gmp=yes])
AC_ARG_WITH(opt-dir,
AS_HELP_STRING([--with-opt-dir=DIR-LIST],