summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authornobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-03-24 14:28:45 +0000
committernobu <nobu@b2dd03c8-39d4-4d8f-98ff-823fe69b080e>2018-03-24 14:28:45 +0000
commit2936d4b378e0bf647a5614e15f7e57cb93518bf3 (patch)
tree36a572847ee5c4f1d1e8478676a115d828600334 /configure.ac
parent4a145f6ea8a462100f4898b8e4cd8bef9bcce570 (diff)
configure.ac: named blocks
* configure.ac: turned section block comments into named blocks. http://c16e.com/1603281120/ git-svn-id: svn+ssh://ci.ruby-lang.org/ruby/trunk@62910 b2dd03c8-39d4-4d8f-98ff-823fe69b080e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 5 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index e905739db0..ffe76a6618 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,8 +19,7 @@ AC_ARG_VAR([cflags], [additional CFLAGS])
AC_ARG_VAR([cppflags], [additional CPPFLAGS])
AC_ARG_VAR([cxxflags], [additional CXXFLAGS])
-{ # environment section
-
+: "environment section" && {
HAVE_BASERUBY=yes
AC_ARG_WITH(baseruby,
AS_HELP_STRING([--with-baseruby=RUBY], [use RUBY as baseruby; RUBY is the pathname of ruby]),
@@ -378,10 +377,9 @@ AS_IF([test -f conf$$.dir/src/cdcmd], [
rm -fr conf$$.dir
AC_MSG_RESULT([$CHDIR])
AC_SUBST(CHDIR)
-
}
-{ # compiler section
+: "compiler section" && {
RUBY_WERROR_FLAG([
AC_MSG_CHECKING([whether CFLAGS is valid])
AC_TRY_COMPILE([], [],
@@ -673,10 +671,9 @@ AC_ARG_WITH(opt-dir,
test -z "${ac_env_CFLAGS_set}" -a -n "${cflags+set}" && eval CFLAGS="\"$cflags $ARCH_FLAG\""
test -z "${ac_env_CXXFLAGS_set}" -a -n "${cxxflags+set}" && eval CXXFLAGS="\"$cxxflags $ARCH_FLAG\""
-
}
-{ # header and library section
+: "header and library section" && {
AC_ARG_WITH(winnt-ver,
AS_HELP_STRING([--with-winnt-ver=0xXXXX], [target Windows NT version (default to 0x0501)]),
[with_winnt_ver="$withval"], [with_winnt_ver="0x0501"])
@@ -2413,11 +2410,9 @@ main(int argc, char *argv[])
rb_cv_fork_with_pthread=yes)])
test x$rb_cv_fork_with_pthread = xyes || AC_DEFINE(CANNOT_FORK_WITH_PTHREAD)
])
-
-
}
-{ # runtime section
+: "runtime section" && {
dnl wheather use dln_a_out or not
AC_ARG_WITH(dln-a-out,
AS_HELP_STRING([--with-dln-a-out], [use dln_a_out if possible]),
@@ -3219,8 +3214,8 @@ AS_IF([test x"$gcov" = xyes], [
RUBY_SETJMP_TYPE
}
-{ # build section
+: "build section" && {
dnl build rdoc index if requested
RDOCTARGET=""
CAPITARGET=""