summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Wu <XrXr@users.noreply.github.com>2022-03-31 17:26:28 -0400
committerGitHub <noreply@github.com>2022-03-31 17:26:28 -0400
commit222203297966f312109e8eaa2520f2cf2f59c09d (patch)
tree5bae93372d656f43f443ee22873a7db57fe1119e /configure.ac
parent056b7a86335f38618c1749674a11e838de7c3c12 (diff)
Remove dependency on libcapstone
We have received reports of build failures due to this configuration check modifying compile flags. Since only YJIT devs use this library we can remove it to make Ruby easier to build for users. See: https://github.com/rbenv/ruby-build/discussions/1933
Notes
Notes: Merged: https://github.com/ruby/ruby/pull/5744 Merged-By: XrXr
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 0 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 603cbebd03..0357a7eacf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1268,15 +1268,6 @@ AC_CHECK_LIB(crypt, crypt) # glibc (GNU/Linux, GNU/Hurd, GNU/kFreeBSD)
AC_CHECK_LIB(dl, dlopen) # Dynamic linking for SunOS/Solaris and SYSV
AC_CHECK_LIB(socket, shutdown) # SunOS/Solaris
-AS_IF([test -n "${PKG_CONFIG}" && ${PKG_CONFIG} --exists capstone], [
- CAPSTONE_CFLAGS=`${PKG_CONFIG} --cflags capstone`
- CAPSTONE_LIB_L=`${PKG_CONFIG} --libs-only-L capstone`
- LDFLAGS="$LDFLAGS $CAPSTONE_LIB_L"
- CFLAGS="$CFLAGS $CAPSTONE_CFLAGS"
-])
-
-AC_CHECK_LIB(capstone, cs_open) # Capstone disassembler for debugging YJIT
-
dnl Checks for header files.
AC_HEADER_DIRENT
dnl AC_HEADER_STDC has been checked in AC_USE_SYSTEM_EXTENSIONS