summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMaxime Chevalier-Boisvert <maxime.chevalierboisvert@shopify.com>2022-12-12 15:13:46 -0500
committerGitHub <noreply@github.com>2022-12-12 15:13:46 -0500
commit1004d693b7a3db5db98be59a3d3d468d2ee21ca5 (patch)
tree31edb6e49fb2dc3a3dd2b9e3fbdc4ec4be8718f5 /configure.ac
parent8e619b8e0ebbfd2e6ceb9fa69d67846796eb716e (diff)
Make it so YJIT is no longer marked as experimental (#6909)
Tested on production workloads at Shopify for > 1 year and proven to be quite stable. Enabling YJIT at run-time is still guarded behind the --yjit command-line option for now.
Notes
Notes: Merged-By: maximecb <maximecb@ruby-lang.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ae560297ad..ce47ab7b16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3785,7 +3785,7 @@ AS_IF([test "$cross_compiling" = no],
dnl build YJIT in release mode if rustc >= 1.58.0 is present and we are on a supported platform
AC_ARG_ENABLE(yjit,
AS_HELP_STRING([--enable-yjit],
- [enable experimental in-process JIT compiler that requires Rust build tools [default=no]]),
+ [enable in-process JIT compiler that requires Rust build tools [default=no]]),
[YJIT_SUPPORT=$enableval],
[AS_CASE(["$enable_jit_support:$YJIT_TARGET_OK:$YJIT_RUSTC_OK"],
[yes:yes:yes|:yes:yes], [