summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2022-10-30 18:22:50 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2022-10-30 19:16:09 +0900
commit0717cb84193083cbfb7daee115a82418fd9c1474 (patch)
tree307aa1c6fe296902a97769cd35374ad03ca3556c /configure.ac
parent28214231055d3baf3ee4191520736691146e29c1 (diff)
Try -fstack-protector-strong on MinGW
The CI for MinGW has used it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 711ff997e7..87966fdfcf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -794,7 +794,7 @@ AS_IF([test "$GCC" = yes], [
# -fstack-protector
AS_CASE(["$target_os"],
- [mingw*|emscripten*|wasi*], [
+ [emscripten*|wasi*], [
stack_protector=no
])
AS_IF([test -z "${stack_protector+set}"], [
@@ -806,6 +806,8 @@ AS_IF([test "$GCC" = yes], [
AS_IF([test "x$stack_protector" = xyes], [stack_protector=option; break])
])
])
+ AC_MSG_CHECKING([for -fstack-protector])
+ AC_MSG_RESULT(["$stack_protector"])
AS_CASE(["$stack_protector"], [-*], [
RUBY_APPEND_OPTION(XCFLAGS, $stack_protector)
RUBY_APPEND_OPTION(XLDFLAGS, $stack_protector)