summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNobuyoshi Nakada <nobu@ruby-lang.org>2020-06-04 10:26:40 +0900
committerNobuyoshi Nakada <nobu@ruby-lang.org>2020-06-04 13:16:24 +0900
commit047471c52960e32146025fab064487d25f92a141 (patch)
treee970f67bb9b8c838b6f87552b959a4e7a6110e26 /configure.ac
parent3d7138871079d02b31c05ca6af943d56365a8776 (diff)
No GITPULLOPTIONS by default
To honor the environment variable, keep GITPULLOPTIONS unset by default, and appended the option to VCSUP.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 71e71dd47a..d4dbbf81fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4055,7 +4055,7 @@ AC_CONFIG_FILES(Makefile:template/Makefile.in, [
VCS='echo cannot'
])
AS_CASE("$VCS",
- ['$(GIT)'|git], [VCSUP='$(VCS) pull $(GITPULLOPTIONS)'],
+ ['$(GIT)'|git], [VCSUP='$(VCS) pull --rebase $(GITPULLOPTIONS)'],
[VCSUP='$(VCS)'])
sed -n \
-e '[/^@%:@define \(RUBY_RELEASE_[A-Z]*\) \([0-9][0-9]*\)/]{' \