summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index dc96f2f1de..fb3b86e76b 100644
--- a/configure.in
+++ b/configure.in
@@ -1505,6 +1505,12 @@ EOH
])dnl
])dnl
+AC_CACHE_CHECK(for typeof, rb_cv_typeof,
+ [AC_TRY_COMPILE([int i; typeof(i) j;], [], [rb_cv_typeof=yes], [rb_cv_typeof=no])])
+if test "$rb_cv_typeof" = yes; then
+ AC_DEFINE(HAVE_TYPEOF)
+fi
+
dnl RUBY_FUNC_ATTRIBUTE(attrib, macroname, cachevar, condition)
AC_DEFUN([RUBY_FUNC_ATTRIBUTE], [dnl
m4_ifval([$2], dnl