summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.in b/configure.in
index ecb3a36ca2..6888087964 100644
--- a/configure.in
+++ b/configure.in
@@ -289,13 +289,7 @@ AC_PROG_GCC_TRADITIONAL
AC_SUBST(GCC)
if test "$GCC" = yes; then
linker_flag=-Wl,
- if test "$CC -v 2>&1 | grep LLVM" ; then
- # llvm-gcc's optimization strategy is far different from gcc.
- # It makes confusing our gcc specific optimized code.
- : ${optflags=-O0}
- else
- : ${optflags=-O3}
- fi
+ : ${optflags=-O3}
AS_CASE(["$target_os"], [linux*|darwin*], [: ${debugflags=-ggdb}])
RUBY_APPEND_OPTIONS(XCFLAGS, ["-include ruby/config.h" "-include ruby/missing.h"])
else