summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a858fedc81..973256a142 100644
--- a/configure.in
+++ b/configure.in
@@ -239,13 +239,17 @@ fi
AC_PROG_CC
AC_PROG_CXX
AC_PROG_GCC_TRADITIONAL
-test $ac_cv_prog_cc_g = yes && : ${debugflags=-g}
if test "$GCC" = yes; then
linker_flag=-Wl,
: ${optflags=-O3}
+ case "$target_os" in
+ when(linux*|darwin*)
+ : ${debugflags=-ggdb};;
+ esac
else
linker_flag=
fi
+test $ac_cv_prog_cc_g = yes && : ${debugflags=-g}
RUBY_PROG_GNU_LD
RUBY_CPPOUTFILE