summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 3 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 551306b328..5692eb150e 100644
--- a/configure.in
+++ b/configure.in
@@ -2136,18 +2136,17 @@ test ".$DLEXT" = "." || AC_DEFINE_UNQUOTED(DLEXT, ".$DLEXT")
test ".$DLEXT2" = "." || AC_DEFINE_UNQUOTED(DLEXT2, ".$DLEXT2")
AC_SUBST(DLEXT)
-AC_SUBST(STRIP)dnl
if test "$with_dln_a_out" = yes; then
STRIP=true
else
- STRIP=strip
+ AC_CHECK_TOOL(STRIP, strip, :)dnl
fi
AS_CASE(["$target_os"],
[linux* | gnu* | k*bsd*-gnu | kopensolaris*-gnu], [
- STRIP='strip -S -x'],
+ STRIP="$STRIP -S -x"],
[nextstep* | openstep* | rhapsody* | darwin*], [
- STRIP='strip -A -n'])
+ STRIP="$STRIP -A -n"])
AC_ARG_WITH(ext,
AC_HELP_STRING([--with-ext=EXTS],